RIPv2

RIP (Routing Information Protocol) 路由协议是一种相对古老,在小型以及同介质网络中得到了广泛应用的一种路由协议。RIP 采用距离向量算法,是一种距离向量协议。RIP在RFC 1058文档中定义。 RIP使用UDP报文交换路由信息,UDP端口号为520。通常情况下RIPv1报文为广播报文;而RIPv2报文为组播报文,组播地址为224.0.0.9。RIP每隔30 秒向外发送一次更新报文。如果设备经过180 秒没有收到来自对端的路由更新报文则将所有来自此设备的路由信息标志为不可达,若在240 秒内仍未收到更新报文就将这些路由从路由表中删除。

RIP 使用跳数来衡量到达目的地的距离,称为路由量度。在RIP 中,设备到与它直接相连网络的跳数为0;通过一个设备可达的网络的跳数为1 ,其余依此类推;不可达网络的跳数为16。

RFC 1388 [Malkin 1993a]中对R I P定义进行了扩充,通常称其结果为RIP-2。这些扩充并不改变协议本身,而是利用RIPv1中的一些标注为“必须为0”的字段来传递一些额外的信息。如果RIP忽略这些必须为0的字段,那么,RIP和RIP-2可以互操作。

选路域(routing domain)是一个选路守护程序的标识符,它指出了这个数据报的所有者。在一个Unix实现中,它可以是选路守护程序的进程号。该域允许管理者在单个路由器上运行多个RIP实例,每个实例在一个选路域内运行。

选路标记(routing tag)是为了支持外部网关协议而存在的。它携带着一个EGP和BGP的自治系统号。

每个表项的子网掩码应用于相应的I P地址上。下一站I P地址指明发往目的I P地址的报文该发往哪里。该字段为0意味着发往目的地址的报文应该发给发送RIP报文的系统。

RIP-2提供了一种简单的鉴别机制。可以指定RIP报文的前20字节表项地址系列为0xffff,路由标记为2。表项中的其余16字节包含一个明文口令。

最后,RIP-2除了广播外,还支持多播,也支持可变长子网掩码(VLSM)。这可以减少不收听RIP-2报文的主机的负载。

RIP有RIP-1和RIP-2两个版本。

RIP-1是有类别路由协议(Classful Routing Protocol),它只支持以广播方式发布协议报文。RIP-1的协议报文无法携带掩码信息,它只能识别A、B、C类这样的自然网段的路由,因此RIP-1不支持非连续子网(Discontiguous Subnet)。

RIP-2是一种无类别路由协议(Classless Routing Protocol),与RIP-1相比,它有以下优势:

支持路由标记,在路由策略中可根据路由标记对路由进行灵活的控制。

报文中携带掩码信息,支持路由聚合和CIDR(Classless Inter-Domain Routing,无类域间路由)。

支持指定下一跳,在广播网上可以选择到最优下一跳地址。

支持组播路由发送更新报文,减少资源消耗。

支持对协议报文进行验证,并提供明文验证和MD5验证两种方式,增强安全性。

【说明】RIP-2有两种报文传送方式:广播方式和组播方式,默认将采用组播方式发送报文,使用的组播地址为224.0.0.9。当接口运行RIP-2广播方式时,也可接收RIP-1的报文。

routerA(config)#interface f0/0

routerA(config-if)#ip address 10.1.1.1 255.255.255.0

routerA(config-if)#no shutdown

routerA(config-if)#interface f0/1

routerA(config-if)# ip address 192.168.1.1 255.255.255.0

routerA(config-if)#no shutdown

routerB(config)#interface f0/0

routerB(config-if)#ip address 10.1.2.1 255.255.255.0

routerB(config-if)#no shutdown

routerB(config)#interface f0/1

routerB(config-if)#ip address 192.168.1.2 255.255.255.0

routerB(config-if)#no shutdown

routerC(config)#interface f0/0

routerC(config-if)#ip address 192.168.1.3 255.255.255.0

routerC(config-if)#no shutdown

routerC(config)#interface f0/1

routerC(config-if)#ip address 192.168.2.1 255.255.255.0

routerC(config-if)#no shutdown

routerA(config)#router rip (设置路由协议为RIP)

routerA(config-router)#version 2

routerA(config-router)#no auto-summary (关闭路由协议的自动汇总功能)

routerA(config-router)#network 10.0.0.0

routerA(config-router)#network 192.168.1.0

routerB(config)#router rip

routerB(config-router)#version 2

routerB(config-router)# no auto-summary

routerB(config-router)#network 10.0.0.0

routerB(config-router)#network 192.168.1.0

routerC(config)#router rip

routerC(config-router)# version 2

routerC(config-router)# no auto-summary

routerC(config-router)#network192.168.1.0

routerC(config-router)#network 192.168.2.0

1)查看路由表

router#show ip route

2)查看路由协议配置

router#show ip protocols

3)打开RIP协议调试命令

router#debug ip rip

在PC上设置IP地址、子网掩码、默认网关,用ping命令测试连通性

相关词汇